No action bar displayed when accessing from email

15 09 2010

I recently discovered another weird quirk in workflow relating to jumping directly to a record in AX from an email notification. If you are running in a multi-company environment and the user’s default company is different from the company in which the workflow document resides, the yellow workflow bar will not be displayed when accessing the record directly via the drill-down functionality in workflow notification emails, assuming that there was no already opened AX client. Re-opening the form manually reveals the workflow bar.

It appears that the sequence in which the AX client and user defaults are loaded causes the SysWorkflowFormControls class to not be in the correct company context when trying to load the necessary workitems/actions for the record in question.

Solution:
My work-around for this is to perform a manual changecompany around the code in the SysWorkflowFormControls.showWorkItemActions method.

e.g.

changecompany(_workItemTable.CompanyId)
{
...
}

I hope this helps someone resolve this rather strange error.

Regards
Jonathan

Advertisements

Actions

Information

One response

12 09 2014
free dating sites

I am regular visitor, howw aree yyou everybody?
Thhis paragraph posted at this site is actually pleasant.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: